Array Overflow in MSM V4L2 Video Driver Allows Kernel Memory Corruption (CVE-2016-2061)

Release Date: 
June 6, 2016
Advisory ID: 
QCIR-2016-00014-1
Summary: 

CVE-2016-2061
In function msm_isp_axi_create_stream, the upper bound of stream source is compared against VFE_AXI_SRC_MAX, however the operation is signed, so an invalid value between -1 to INT_MIN can still pass the check, and results in the invalid value used as an index.

Access Vector: Local
Security Risk: High
Vulnerability: CWE-129 Improper Validation of Array Index

Affected Versions:
All Android releases from CAF using the Linux kernel.

Patch: 

We advise customers to apply the following patches:

Individual Patches

  • https://us.codeaurora.org/cgit/quic/la//kernel/msm-3.18/commit/?id=79db14ca9f791a14be9376a0340ad3b9b9a4d603

  • Acknowledgement: 

    This issue has been reported to Google by an external researcher. We thank Google for bringing this issue to our attention.

    Revisions: 
    Initial revision
    Contact: 
    security-advisory@quicinc.com