Heap Overflow/LPE in MediaServer (libOmxVdec) (CVE-2016-6758)

Release Date:

December 6, 2016

Affected Projects:

Android for MSMFirefox OS for MSMQRD Android

Advisory ID:

QCIR-2016-00073-1

CVE ID(s):

CVE-2016-6758

Summary:

The following security vulnerabilities have been identified: CVE-2016-6758 When a client calls omx_vdec::use_input_heap_buffers for a secure session, the allocated buffer is too small to hold only buffer header for "secure". When omx_vdec::empty_this_buffer_proxy is called, component ends up copying a larger size than what was allocated and thus overwrites memory.

Access Vector: Local
Security Risk: High
Access Vector: Local

Affected Versions:

All Android releases from CAF using the Linux kernel.

Patch:

We advise customers to apply the following patches:

Individual Patches

CVE-2016-6758: 

https://www.codeaurora.org/gitweb/quic/la/?p=platform/hardware/qcom/media.git;a=commit;h=179fe774bfcde5cf75bc43ee176b0bcd75edac08

 

Acknowledgement:

This issue was reported to Google by an external security researcher. Qualcomm Innovation Center, Inc. (QuIC) thanks Google for bringing this issue to QuIC's attention.

Revisions:

Initial

Contact:

security-advisory@quicinc.com