Improper input validation in the tethering controller of netd (CVE-2016-2060)

Release Date:

May 5, 2016

Affected Projects:

Android for MSMFirefox OS for MSMQRD Android

Advisory ID:

QCIR-2016-00001-1

CVE ID(s):

CVE-2016-2060

Summary:

The following security vulnerability has been identified in the QuIC-customized network service. CVE-2016-2060: The netd service does not properly validate the interface name when a new upstream interface is added. This invalid name is then susceptible to be used as an argument in subsequent system commands.

Access Vector: Local
Security Risk: Medium
Access Vector: Local

Affected Versions:

All Android releases from CAF using the following heads: jb, kk, lp

Patch:

We advise customers to apply the following patches:

Individual Patches
netd change:

Acknowledgement:

Qualcomm Innovation Center, Inc. (QuIC) thanks Jake Valletta from Mandiant, A FireEye Company, for reporting the related issues and working with QuIC to help improve Android device security.

Revisions:

Initial revision

Contact:

security-advisory@quicinc.com