Improper input validation while updating power data for energy aware feature (CVE-2016-3906)

Release Date:

November 11, 2016

Affected Projects:

Android for MSMFirefox OS for MSMQRD Android

Advisory ID:

QCIR-2016-00054-1

CVE ID(s):

CVE-2016-3906

Summary:

The following security vulnerabilities have been identified: CVE-2016-3906 When processing add_to_ptable() with a huge 64bit input value (e.g., 0x2222222200000000) the return statement that prevents that len will be greater than MAX_PSTATES can be avoided and hence, len can be greater than MAX_PSTATES. This can result in a kernel information leak when msm_core_ptable_read() that calls print_table() is executed.

Access Vector: Local
Security Risk: Medium
Access Vector: Local

Affected Versions:

All Android releases from CAF using the Linux kernel.

Patch:

We advise customers to apply the following patches:

Individual Patches

Acknowledgement:

This issue was reported to Google by Gengjia Chen (@chengjia4574) and pjf (weibo.com/jfpan) of IceSword Lab, Qihoo 360. Qualcomm Innovation Center, Inc. (QuIC) thanks Google for bringing this issue to QuIC's attention.

Revisions:

Updated revision. Updated acknowledgment section on Dec. 6, 2016.

Contact:

security-advisory@quicinc.com