Information leak in SCM driver (CVE-2016-8414)

Release Date:

February 14, 2017

Affected Projects:

Android for MSMFirefox OS for MSMQRD Android

Advisory ID:

QCIR-2017-00005-1

CVE ID(s):

CVE-2016-8414

Summary:

The following security vulnerabilities have been identified: CVE-2016-8414 When handling some ioctl commands, for example QSEECOM_IOCTL_CREATE_KEY_REQ, certain physical memory addresses that correspond the kernel virtual addresses can be leaked to user space.

Access Vector: Local
Security Risk: Medium
Access Vector: Local

Affected Versions:

All Android releases from CAF using the Linux kernel.

Patch:

We advise customers to apply the following patches:

Individual Patches

CVE-2016-8414:

https://www.codeaurora.org/gitweb/quic/la/?p=kernel/msm-3.10.git;a=commit;h=6fd98d440f8b65958be125f91ae90ec827ae9507

 

Acknowledgement:

This issue was reported to Google by an external security researcher. Qualcomm Innovation Center, Inc. (QuIC) thanks Google for bringing this issue to QuIC's attention.

Revisions:

Initial revision

Contact:

security-advisory@quicinc.com