Privilege Escalation Vulnerability in Graphics Driver (CVE-2016-2067)

Release Date:

July 5, 2016

Affected Projects:

Android for MSMFirefox OS for MSMQRD Android

Advisory ID:

QCIR-2016-00020-1

CVE ID(s):

CVE-2016-2067

Summary:

When user memory of type KGSL_USER_MEM_TYPE_ADDR is mapped to the GPU driver, a logic error causes read-only user pages to be mapped as read-write in the GPU driver, allowing memory corruption and privilege escalation.

Access Vector: Local
Security Risk: High
Access Vector: Local

Affected Versions:

All Android releases from CAF using the Linux kernel.

Patch:

We advise customers to apply the following patch:
Individual Patch

Acknowledgement:

Qualcomm Innovation Center, Inc. (QuIC) thanks Justin Taft of NCC Group for reporting the related issues and working with QuIC to help improve Android device security.

Revisions:

Initial revision

Contact:

security-advisory@quicinc.com